Honda Insight Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Ima system inop. Before and after new hybrid battery replaced by green tech. Also engine check light on and won’t reset. Scanner.codes p1129,p1635,p1576,p0141 showed at time of new battery installation . New tech battery tech said the battery system was as it should be . Took car to hybrid shop they had it for two weeks and could not fix it . Car can be driven but no ima and Ecl won’t reset car is 03 automatic with about 112k miles. Had car for over5 years started having issues a couple years ago but was able to reset ima and carry on replaced bcm once with eBay unit which seemed to help . Still driving car but sure could use some suggestions, thanks to all.
 

·
Administrator
Joined
·
13,706 Posts
You can't clear the CEL until you fix the faults.

Non IMA related.
P1129 MAP Sensor issue. Lots of hits on here.
P0141 O2 Sensor issue. Lots of hits on here.

IMA related.
P1635 BCM Module Issue. Lots of hits on here. We need the subcodes.
P1576 MDM Voltage Issue. Ditto.
 

Attachments

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
Thank You for the info.
Iam still working on this problem ,replaced fuel air mixture sensor ( upstream O2 sensor) seemed to help eliminate some fuel mixture related codes . Ima problem still exists , when engine first starts with ima starter ,ima light is off for a couple seconds and ima shows three charging bars for about two seconds,then ima light comes on . Checked ima battery voltage with key on read 15 volts ,started engine volts up to 60 volts 2k rpm 120 volts 3k rpm 200 plus volts. I suspect my new Green Tech lithium ion battery is defective, any thoughts here? Always appreciate the reply’s Thanks Steve Dark Blue Cvt 112K
 
1 - 6 of 6 Posts
Top