Honda Insight Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
So I admit it... I'm 13 years behind the times. I bought a 2000 Insight (red) in Oct of 2013. I've always wanted one, now I (finally) own one. The first 2 months were amazing. I went head first into hypermiling & on my 22 mile commute to work averaged 94mpg once & over 80mpg multiple times. Then it happened. My dream car began bucking & kicking during lean burn, the check engine light came on (P0420) & the IMA started falling off. I reset a few times (disconnected the 12V) & replaced the O2 sensor (bank 1) but w/in days it's right back where it started - all the while my mpg's have been suffering terribly (tank avg of 50 vs previous tank avg of 65). This is a 100% stock 00 - I'm saving for a grid charger but am thinking a CAT will be first. I need your expert advise as I am no mechanic & an Insight newb. Thanks in advance for your words of wisdom.

PS: since getting my 00 in Oct my wife has been so amazed at the mpg she has agreed to sell/trader her 03 Expedition 4X4 V8 for a new (used - new to us) Prius/Insight.

Thanks - Andy - Conway, AR (if there are any 1st Gen mechanics in AR I'd love to support you/your business)
 

·
Moderator
Joined
·
7,200 Posts
Make sure the ECM update has been done.

If it is the cat, they are available rebuilt for much cheaper than a brand new one, that is your best bet.

Feel free to give us a call to discuss - I'm available now. :)
 
1 - 3 of 3 Posts
Top