Honda Insight Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi all,

I'm a new (used car) 2010 Insight owner...I pick it up in a couple of days.
But I'm interested in replacing the stock head unit.

Its got steering wheel controls so I want to preserve this function.

I want to replace it with an Atoto A6 nav stereo player from China.

And add an Atoto back up camera

The new unit has steering control wiring, navigation, Wifi/bluetooth etc...

Question is...what else do I need in terms of harnesses or connections to make this project work? And how do I connect the whole thing up so it works properly?

I've sourced a double din fascia fitting kit also from China.

Cheers all.
 

·
Registered
Joined
·
2 Posts
Hi,
I have bought an ATOTO A6 2din android radio and I'm going to replace the stock radio... The guide on removing the stock radio of insightcentral works very well but I had some issue while connecting the new radio... ATOTO service suggested me some harness to fit the unit with. I started with the ISO A connector but got only half audio channel (the right door speaker) so I turned to the ISO B connector... this time both the speaker (left and right door) worked but... after playing with the radio settings (the box not yet fitted in place) I ended up with low battery simptoms: lights fading, engine not starting, dash flashing with the turning of the key but then darkening out... I was in panic. Fitted back the stock radio and nothing changed: the car seemed electrically compromised.
After a night in the garage I turned the key and the car started with no symptoms except for the radio display asking the code ... accepting it with no problem. Any bluetooth phone kept in the memory. Now I'm uncertain what the issue was...
Worked I too much time with the doors opened? Did the car electric circuit react as per a theft try?

If you endend succesfully with the whole operations, could you be so kind to let me know ? Did you find the same problem with electric? I'm specially concerned about the connection with the rear camera: where the system gets the signal for the
engaging of the rear gear?

Thanks,
 

·
Registered
Joined
·
384 Posts
Hi,
I have bought an ATOTO A6 2din android radio and I'm going to replace the stock radio... The guide on removing the stock radio of insightcentral works very well but I had some issue while connecting the new radio... ATOTO service suggested me some harness to fit the unit with. I started with the ISO A connector but got only half audio channel (the right door speaker) so I turned to the ISO B connector... this time both the speaker (left and right door) worked but... after playing with the radio settings (the box not yet fitted in place) I ended up with low battery simptoms: lights fading, engine not starting, dash flashing with the turning of the key but then darkening out... I was in panic. Fitted back the stock radio and nothing changed: the car seemed electrically compromised.
After a night in the garage I turned the key and the car started with no symptoms except for the radio display asking the code ... accepting it with no problem. Any bluetooth phone kept in the memory. Now I'm uncertain what the issue was...
Worked I too much time with the doors opened? Did the car electric circuit react as per a theft try?

If you endend succesfully with the whole operations, could you be so kind to let me know ? Did you find the same problem with electric? I'm specially concerned about the connection with the rear camera: where the system gets the signal for the
engaging of the rear gear?

Thanks,
Haven't a clue but very interested,and obviously hope you get it sorted, someone here must know what's the likely problem,hint hint 🤷guy needs help so pls do
 

·
Registered
Joined
·
2 Posts
I found the main cause of the problem was the steering wheel control retaining interface - once I took out that from the harness everything went ok! Some youtube videos from Connects2 showed what was wrong: their interface can jam can bus if not applied correctly (like I did). Apart from the SWC issue the radio ATOTO works well - the rear camera works, the dashcam works, gps works.
P.S:
in the middle of meddling with car wiring and new stereo when the car gets jammed (no turning on, erratic working of accessory, dashboard lights showing errors door locked or unlocked, and so on, try to re start the car putting the gear in the N position instead of P... for me it worked like a reset - everything turned ok.
 
1 - 4 of 4 Posts
Top