Honda Insight Forum banner

Assist/Charge Dashboard Display Question

2292 Views 4 Replies 3 Participants Last post by  Rick
Hi All:

I just bought a used 2001 Insight. While I'm generally very pleased with the car and have gotten a lot of useful information from this forum, I have a question about a minor problem I'm having with the Assist/Charge meter on the dashboard.

I understand how the lines in the meter work and all that but on my Insight the far left side of the charge display and the far right side of the assist display have solid colored "chunks" of light that are somewhat rectangular shaped but with irregular edges. As the IMA either goes into assist or charge mode you can see the lighted lines going into these areas. It's kind of annoying because it's hard to tell just how the IMA is working but aside from that is it a sign of trouble?

Thanks!
See less
Hi All:

I just bought a used 2001 Insight. While I'm generally very pleased with the car and have gotten a lot of useful information from this forum, I have a question about a minor problem I'm having with the Assist/Charge meter on the dashboard.

I understand how the lines in the meter work and all that but on my Insight the far left side of the charge display and the far right side of the assist display have solid colored "chunks" of light that are somewhat rectangular shaped but with...
See more
1 - 1 of 1 Posts

· Registered
2000 Citrus manual Insight
Joined
·
564 Posts
SamuraiSam said:
Thanks for the info, Rick. I wanted to add that while driving home from work yesterday aftertoon the "leakage" areas on both side of the display cleared up and everything looked normal except for a piece about the size of a match head in the assist portion of the display. Going to work this morning the display looked like it had before (with the "blobs" on the display). Does the "leakage" from the LED go someplace and come back at random?
I've had the problem for a while. The "Blob" comes and goes. Very hot temperatures seem to make it a little better, while it seems worse in the winter. While making a 250+ mile drive on monday, the "Blob" completely vanished. Today it is so bad that I have a hard time telling if I'm using assist or not. Along with Ebay, you might try a salvage yard, unless like me, you can deal with the annoyance.
 
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top