Honda Insight Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
2001 MT - Car runs great after ECU "flash" with commute miles in the high '60's then slowly down cycles over the next couple of hundred miles to the tune of misfire, poor mileage and powerloss. Upstream A/F and downstream o2 replaced.
Good compression, etc. I wish I could just tell the ECU to keep doing what it does after reset. ANY IDEAS ?
 

·
Registered
Joined
·
610 Posts
2001 MT - Car runs great after ECU "flash" with commute miles in the high '60's then slowly down cycles over the next couple of hundred miles to the tune of misfire, poor mileage and powerloss. Upstream A/F and downstream o2 replaced.
Good compression, etc. I wish I could just tell the ECU to keep doing what it does after reset. ANY IDEAS ?

What is a "flash" (are you just pulling the ECU power and going through the re-learn or are you actually reloading firmware, and if so, what tool are you using)?

Things I fixed on my road to better MPG included repairing the EGR valve (a new cheap valve with hall-effect type produced herky-jerky under low RPM loading out of lean burn). I also found the valve lash far too tight. Also, what year is your car and what make LAF (upstream) sensor did you buy? If your car is a 2001, did the upstream sensor have four or five wires?

NTK is apparently the OEM brand for five wire (00-01) upstream sensors and Denso the OEM brand for four wire (late 01-06) upstream sensors.

I am in the middle of diagnosing what I think is light oil consumption leading to fouling but testing is not complete.
 
1 - 3 of 3 Posts
Top