Honda Insight Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter #1
So its been awhile since I was on here, but I have an issue I was wondering if anyone else knew anything about. About 9 months ago, my fob stopped working, about 2 1/2 months ago, my IMA system stopped working; no assist, no regen, and until you put the key in and turned the key, no power locks or anything worked. Now about 2 months ago the car popped up with a check charging system light, then about 10 minutes later it had a battery light, and another half hour or so later I had a christmas tree light situation on my dash(they were all on) I work as a delivery driver and at the time my Insight was my only car, and all this happened while I was at work, so I couldn't just stop. I parked the car and haven't messed with it until now. I drove her today, just around the block to see how it was doing and to get the fluids flowing, so I charged the 12v battery off my mini for about 10 minutes then took it around the block, still no assist or regen, had a battery light, and check IMA and Charging system lights. Now, I thought the Insight could run without the battery pack plugged in or not working, but am I wrong? Is it possible a dead 12v battery is causing the problem and I meed to replace it, or is it likely something involving the battery maintainer and the battery pack all together? 2011 base model with 65k on the clock.
 

·
Registered
Joined
·
1,651 Posts
If it has the original 12 volt under hood battery it is time to replace it. Very common for a failing battery to make weird things happen.
 
1 - 3 of 3 Posts
About this Discussion
2 Replies
2 Participants
insightsport23
Honda Insight Forum
We’re the ultimate Honda Insight forum to talk about Honda’s hybrid car and its fuel economy and specs!
Full Forum Listing
Top