Honda Insight Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi, first time on this forum so forgive me if this is an old issue that has been discussed before!

I have an error code 12 on my year 2000 cvt, 37,000K's. In the last 6 months it has had a new IMA battery fitted by the Honda dealer, a replacement BCM, MCM and bypass contractor but the fault remains. I have looked into the code 12 fault myself and it seems to be pointing to a circuit failure/incorrect voltage (P0AA7?) in the motor drive module?

I need to get the car going so does anyone know how to fix this? I have run the car with the IMA battery disconnected but I live up a steep narrow hill and the car only has enough grunt to go up it without a passenger (wife not impressed!)

Any help would be great! Thanks.
 

·
Premium Member
Joined
·
2,231 Posts
37,000k is 37 million miles. I think you hold a record for car with the most miles! Contact Guinness book of world record!!

On a serious note, if the battery was just swapped, either something got damaged or they didn't plug something in right.
 

·
Premium Member
2001 5S "Turbo"
Joined
·
11,777 Posts
HV contactor stuck either open or closed. Replace is the only option.
Flash 12= P-1576

HTH
Willie
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
Hi, Sorry, it's 37,000 kilometers. The battery was swapped out about 6 months ago and the car ran fine up until about 5 weeks ago. The car made a buzzing noise and the IMA light came on. I was told that it might be the MCM so I swapped it out but no use. I can start the car normally but after 5 mins of idle there is a noise like a relay clicking and the IMA light comes on. Yesterday I tried it again, same thing so I turned off the ignition, tried again about 2 mins later and the car started on the aux. starter!? IMA light still on.
 

·
Registered
Joined
·
386 Posts
Where do you live? Maybe one of the IC members who lives close by can help you.
 
1 - 7 of 7 Posts
Top