Honda Insight Forum banner

1 - 3 of 3 Posts

·
Administrator
Joined
·
12,113 Posts
Discussion Starter #1
Luckily I own two Insights and recently one played up badly with the herky jerky lean burn at low speeds. I tried the EGR cleaning techniques discussed here, soaking in wd40 and operating valve etc. But sadly this made no difference. I swapped the valve with the one from the other Insight and problem resolved. Now just need to order a new one from local UK Honda dealer, and for info the price here is £190.00! Just have to bite the bullet and pay up. I will open up the old one and post a few photos. I doubt it can be repaired. Regards and thanks for all the info on this site.

Regards.

Peter
 

·
Registered
Joined
·
1,240 Posts
I'm surprised cleaning the valve didn't fix the problem because a new valve is just a clean valve. Is it possible you didn't clean the valve as good as it could have been? I'd hate to see you spend that much money for a new valve.
 

·
Premium Member
Joined
·
4,942 Posts
IIRC there's also a post in here by a local "neighbor" of mine that found the integral lift sensor sometimes malfunction too.

That could explain why cleaning had no effect and the swap fixed it.

Yup :!: here is is:

EGR VALVE DISCOVERY
http://www.insightcentral.net/forum/vie ... php?t=3287

And as outlined by cktman (in his post linked above) with some advanced tools and skills you can test the valve for this type of failure too (before spending any hard earned cash for a replacement). If the test passed "cold" then a heat gun may also be required to add thermal stress similar to what is expreienced during its operation.

HTH! :)
 
1 - 3 of 3 Posts
Top