Honda Insight Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hello All,

I have a 2011 Insight, which has been sitting for about 6 months. Prior to this time, I put about 25,000 miles on the car. Just tried to start it with a new 12v battery (since it was dead) but there is no power in the instrument cluster, none of the lights work either. It's complete darkness. Only thing that works is the emergency lights. The car had an aftermarket alarm installed by the previous owner and the alarm started going off soon as I put in the new battery. So I disabled the alarm wire. (Assuming the alarm is preventing it to start) No difference was resulted in the power to the car.
Now I'm trying to find out what is causing the complete shut off. It has been sitting in a lot and not sure if someone has tried to steal it since the alarm was engaged. Another thing I have seen in some threads is that if the hybrid battery drops below a certain voltage/doesn't get charged for a while, it shuts the car off and doesn't let it start, but then nothing is working here?! Or it can be a blown fuse/relay?!

I really appreciate any help I can get :)
 

·
Registered
Joined
·
790 Posts
12v replacement battery already dead?

Try to get a jump. Once you do get a jump, with the car in park, rev the engine until you see the IMA battery needle indicate charge. Keep it up until it's fully charged.
 
1 - 2 of 2 Posts
About this Discussion
1 Reply
2 Participants
Zwolfe
Honda Insight Forum
We’re the ultimate Honda Insight forum to talk about Honda’s hybrid car and its fuel economy and specs!
Full Forum Listing
Top