Honda Insight Forum banner
461 - 469 of 469 Posts

·
Administrator
Joined
·
13,793 Posts
Discussion Starter · #461 ·
The ST7066 data sheet says it's pin compatible with the HD 44780, but it doesn't say code compatible.
It obviously doesn't work so it's either incompatible, broken or there is some other problem.

It would probably need a code rewrite to work so that's not going to happen. Sorry.
 

·
Administrator
Joined
·
13,793 Posts
Discussion Starter · #462 ·
For LiBCM and OBDIIC&C related issues see this thread.
 

·
Premium Member
00 MT
Joined
·
24 Posts
ObdIIC&C up and running, but it freezes when returning to the main screen from the parameters menu (or at least a center click freezes it, I'm assuming that's how you return).
It also freezes when pressing UP in the main screen. Only way to get it back is to unplug and plug it back in.
No C4 capacitor, otherwise works great.

I also can't seem to set amp hack sw to 1, though I could change pri val to 145 without an issue. Is sw no longer used?
 

·
Administrator
Joined
·
13,793 Posts
Discussion Starter · #464 ·
Is this one you have built yourself?
Post close up pics of the board and what SW version you are using.
Maybe a video of the issue.
 

·
Premium Member
00 MT
Joined
·
24 Posts
It's one I've built, yeah.

I took a video showing the current hack parameter problem I was having (and I missed in the video that center-clicking from parameters hangs the system), and then while recording I discovered the UP button press hang (as well as the parameter menu return) is fixed by gently touching the LCD pins.

I am using the OLED Newhaven display (omitting pin 3, 15, 16 as mentioned a few times in here and in the google sheets doc) which I do understand is not really supported, but I'm hoping the issue is actually a bad solder joint or component value issue as nearly every component was substituted. Solder joints all looked good to me but I can always pop the LCD back off and reflow everything (or put on the normal display I bought). I can take better pictures if you see anything that looks suspect as well.

(buzzer is undersized and bodged on with a bit of scrap component lead)







 

·
Administrator
Joined
·
13,793 Posts
Discussion Starter · #466 ·
Disconnect the middle four LCD pins they are used for other functions like CAN.
The OBDIIC&C now uses a 4 bit BUS.
 

·
Premium Member
00 MT
Joined
·
24 Posts
Update!
Removing the 4 pins seems to briefly fix the problem, but I noticed that U1 gets extremely hot and then the issue returns very quickly.

I'm using this for U1

I'm removing the display to look at solder joints and I assume swap for a more suitable component or find some other issue.

Edit:
Display removed to look at the bottom of the board, and I powered it up for a few minutes on the bench. U1 warms up above room temperature, but not burning-hot like it did with the display attached. The board beeps intermittently. It's hard to determine if wiggling around U1 causes it, but generally manipulating the board will make it beep.
Circuit component Passive circuit component Light Green Blue

Circuit component Green Passive circuit component Hardware programmer Electronic engineering

Passive circuit component Circuit component Green Hardware programmer Resistor
 

·
Administrator
Joined
·
13,793 Posts
Discussion Starter · #468 · (Edited)
Your OLED display probably draws way too much power at 5V for the normal 100ma regulator U1. It's probably shutting down/or browning out due to temp/load.

You will have to replace that with a 500ma rated part and a small heatsink.
 

·
Premium Member
00 MT
Joined
·
24 Posts
It's supposed to draw 65ma typical and 98ma max at 50% checkerboard, but the regulator I'm using is 250ma. I'm going to connect a regular green display this evening with a bunch of minigrabber leads and see how it reacts. I didn't check with the display attached, but it was doing its job when powered on the bench. I'll check how it does under load.

I think I have more of the same regulator around so I can swap it for the same one just in case it's partially failed, but I've got some big 1.5a ones as well.
 
461 - 469 of 469 Posts
Top