Honda Insight Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
I've searched the other threads, but there was no mention of other potential causes.

In summary, a year ago, my 2001 MT insight showed the same code p1456, so I re-tightened the gas cap, the code went away after a few mins of driving.

Now, the code returns. I tightened the gas cap 3+ clicks, reset the code with my OBDII reader. A few days later it returns. I repeat this again, clearing the code. The check engine light comes back a few days later with the same code. I buy a brand new Honda OEM gas cap, reset the code. The code returns again. I drive around for a few days with the check engine light on, just to see if I notice anything wrong. I don't notice any changes in driveability, there isn't hesitation or changes in acceleration or anything.

I think it's fair to say it's not a loose gas cap, since it's new and yes I go 3+ clicks upon tightening.

What's next to troubleshoot?
Thank you in advance.
 

·
Premium Member
Joined
·
10,242 Posts
When you remove the gas cap, does it go Whoooooosh? (losing vacuum)
 

·
Registered
Joined
·
27 Posts
Discussion Starter #4
I forgot to mention, a year ago when the P1456 code appeared. It also read P1542 at the same time. So 2 codes back then. Since then, it's just been P1456, never seen the P1542 again.
 

·
Registered
Joined
·
10 Posts
I've searched the other threads, but there was no mention of other potential causes.

In summary, a year ago, my 2001 MT insight showed the same code p1456, so I re-tightened the gas cap, the code went away after a few mins of driving.

Now, the code returns. I tightened the gas cap 3+ clicks, reset the code with my OBDII reader. A few days later it returns. I repeat this again, clearing the code. The check engine light comes back a few days later with the same code. I buy a brand new Honda OEM gas cap, reset the code. The code returns again. I drive around for a few days with the check engine light on, just to see if I notice anything wrong. I don't notice any changes in driveability, there isn't hesitation or changes in acceleration or anything.

I think it's fair to say it's not a loose gas cap, since it's new and yes I go 3+ clicks upon tightening.

What's next to troubleshoot?
Thank you in advance.
 

·
Premium Member
Joined
·
10,242 Posts
Please include your Location in your Profile. Thank You.
 

·
Premium Member
Joined
·
10,242 Posts
Yes, evap. system.
 

·
Premium Member
Joined
·
10,242 Posts
JS:
Please include your Location in your Profile, as ALL G1 Insighters have done.
Thank You.
Willie
 

·
Premium Member
Joined
·
10,242 Posts
Use the "account settings". Should take about 10 sec. to do.
Are you using a phone or a computer?
 

·
Registered
Joined
·
27 Posts
Discussion Starter #16
update: I took time to really clean the gas cap rubber seal, and also metal gas tank entry point where it seals onto. I reset the code, and it's been a week driving with no code showing back up. I'll update again if it shows back up. But I guess it was a bit gritty, not allowing a complete seal... go figure lol.

Here's a Honda EVAP troubleshooting guide, in case the gas cap isn't the issue for other folks, the Insight being one of the vehicles listed.
 
1 - 17 of 17 Posts
Top