Honda Insight Forum banner

1 - 20 of 26 Posts

·
Registered
Joined
·
157 Posts
Discussion Starter #1
I was driving my Insight home today and all of a sudden I got a check engine light and an IMA light. Everything was acting normal, except I had no assist or charge. When I got home, I turned it off and restarted it. I only had the check egine light and assist and charge were back working. All was ok except for the light. I have a 'Carchip' to read trouble codes, so I plugged it in and it came up with a P1585, which I found on the internet to mean 'P1585 Motor Current Signal Circuit Problem'. My carchip can reset the check engine light, so I had it do that and I drove it tonight with no problems and no check engine light.

Anyone have any info on this and if it means a pending failure coming soon?

Thanks.
 

·
Premium Member
Joined
·
830 Posts
Maybe showing it to a dealer before resetting it would have been a wise choice (still under warranty) so that if something happens in the future, you would have this data to point to a problem
 

·
Registered
Joined
·
157 Posts
Discussion Starter #5
Thought of that, but I've got 37500 miles and it is no longer under warrantee. Although maybe the IMA 80000 warrantee might have taken effect. We'll see if it comes back. It is working great so far today.

For the carchip question, it is a low cost OBD reader. You need a PC to download the data to look at. The only problem with it for the Insight is that when you autostop, the Carchip stops logging data until you turn off the car and start it up again.

See http://www.davisnet.com/drive/products/ ... oducts.asp for more info.
 

·
Registered
Joined
·
41 Posts
Interesting that the web site says hybrid vehicles are not supported.
 

·
Registered
Joined
·
157 Posts
Discussion Starter #7
Yes, I've emailed them and discussed it. They were under the impression that with no ICE running, ie Prius, that they could not identify that it was running. I told them it runs fine with the Insight - it's just that when it autostops, the CarChip times out and shuts off - I guess so it doesn't keep logging with the car not running. I asked them if they could just increase the timeout to 2 minutes or somthing, it would work fine. But so far, no results from them.

But it does work fine for reading OBD codes and all. It logs good too until the first Autostop that lasts longer that 10 seconds or so.
 

·
Registered
Joined
·
157 Posts
Discussion Starter #8
Just a week after the last code, I just now got a P1440 code. I had this code happen to me last June also. My Insight used the aux started, but assist worked ok. I took it into the dealer and they couldn't find anything, but Honda recommended that they change the 12 volt battery - that false readings could occur. Well, it's been over 2 years on my stock battery, so I thought, why not, let's try it. They told me if I get another error code in the next few months that they would not charge me the $90 diagnostic fee.
 

·
Registered
Joined
·
157 Posts
Discussion Starter #9
Well, it happened again today. Got an IMA light and a Check engine light, now I don't have autostop and it uses the aux starter. I still have assist though. I will be calling my dealer again. Something needs to be replaced.
 

·
Registered
Joined
·
2,448 Posts
Make sure your 12 volt battery is staying charged. With problems like this the DC/DC converter may be dead and that would mean all 12 volt power is comming from the little battery under the hood.
 

·
Registered
Joined
·
157 Posts
Discussion Starter #11
I assume they have a good test for that, right? Should be fairly obvious to a trained technician. -- Oops, maybe that's the problem! :)
 

·
Premium Member
Joined
·
830 Posts
And make sure the engine/transmission/ground cables are OK. Although I had P1580 and P1586 with the bad ones.

Your 12V battery still had some life into it since it could start the engine. But replacement after 3 years is a must, to my knowledge (the OEM is not long lasting)
 

·
Registered
Joined
·
157 Posts
Discussion Starter #14
My Insight is in the shop. They want to keep it overnight now. They have been talking to Honda and Honda wants to do some more tests in the morning. So far, they don't know what's wrong. I have a 1440 code, a 1600 code and a 1647 code. The good news for me is that I have codes they can look at, unlike some fellow Insighter's that know there is a problem, but no code, no problem.

Other than no autostop and the aux starter being used, it runs great, so I'm guessing a senser problem of some sort.
 

·
Registered
Joined
·
157 Posts
Discussion Starter #15
Insight still in shop. No news yet. Apparently Honda asked if there were any additions to the car, like amplifiers and such. Said that that might cause a problem - whatever that means. I did put a different head unit in, but that's it.
 

·
Registered
Joined
·
157 Posts
Discussion Starter #16
My service advisor just called. Honda wants them to replace the PCM. I think that's what she said. I'm not sure what the PCM is. She said they expect this to solve the problem, but not 100% sure, but they need to start there. They expect to have one drop shipped by noon tomorrow.
 

·
Registered
Joined
·
157 Posts
Discussion Starter #17
The part didn't come in Friday. They put a rush on it. Not sure when it will be here. They gave me a loaner - a Honda van! I told my wife if we need to haul something, now's the time!
 

·
Registered
Joined
·
157 Posts
Discussion Starter #20
Latest news. I guess they were trying to find a part in the US, but now decided that they need to get one from Japan. Not sure on the time frame yet. I am starting to get impatient. The loaner Honda van works well (my wife likes that we can buy BIG things), but I hate seeing that gas gauge go down so fast. I miss my Insight.
 
1 - 20 of 26 Posts
Top