Honda Insight Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
138 Posts
Discussion Starter #1
Well my new blue 2004 toy has it own set of problems which of course end up being emissions related.

Regen works but assist doesnt. The only codes are the ones above. The P2A00 seems rare but if you look at this picture it appears someone wired in the O2 sensor directly. I am not sure sure what cable goes where to confirm if they did it right or possibly have the wrong O2 sensor which seems common also....

I have ground cables and a 3rd gridcharger cable on order. I am not sure if I should go right after the O2 sensor or replace ground cables, do some fuel cleaner and grid charge it first.....

Thoughts? Feelings? Suggestions?
 

·
Registered
Joined
·
138 Posts
Discussion Starter #3
BUMP any quick way to confirm they wired this right?
 

·
Super Moderator
Joined
·
4,690 Posts
Are the wires at each end of the splices the same color? This is probably a repair of rodent damage.

Sam
 

·
Premium Member
Joined
·
9,683 Posts
Four wires VS five?
Wrong sensor?
Willie
 

·
Registered
Joined
·
138 Posts
Discussion Starter #6
Four wires VS five?
Wrong sensor?
Willie
It's 4 wires and colors don't really match since they are different on either side...should there be 5 on a 2004 MT?
 
1 - 6 of 6 Posts
About this Discussion
5 Replies
3 Participants
turbogizzmo
Honda Insight Forum
We’re the ultimate Honda Insight forum to talk about Honda’s hybrid car and its fuel economy and specs!
Full Forum Listing
Top