Honda Insight Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Bought my 200 Insight last December and a few weeks ago the sound cut out on my JVC CD/radio followed by faint smell of smoke. All the LEDs work on the receiver but no sound at all, no static, or anything can be heard from the speakers. I checked all fuses but they are OK.

Before I bring it into a car audo shop does anyone have any suggestions?
 

·
Registered
Joined
·
89 Posts
Select a replacement from Crutchfield and change the head unit yourself.

Sounds like your old one is fried.

Regards,
 

·
Registered
Joined
·
2,448 Posts
Sounds like your internal amplifier in the head unit fried. There is a slight possibilit that the pre amp outputs still work so you *might* (heavily stressed) be able to just add an external amplifier and have everything working again, but with more power.

Replacing the stereo yourself is pretty easy actually, so I'd consider that before I let an audio shop hack in to your car.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
no radio sound

Bought a new unit ($170 JVC 200W)and still no sound. Just like the old one, all the LEDs work, radio and CD seems to be playing just no output sound.

I'm thinking it may be the wire harness or the speakers themselves. Now I'm reaerching on how to access the speakers

Everything seemed to be working fine prior to all this. I was cranking a song by the Kinks. Maybe it didn't like the song.
 
1 - 4 of 4 Posts
Top